Error while upgrade from 2.6.2 to 2.7.0

12.11.2012 06:04
#1
Scale
Joomshopping forum user no avatar
Name: Scale
11.01.2012
Posts: 2
Quote
Error while upgrade from 2.6.2 to 2.7.0

I have received error while I upgrade joomshopping from 2.6.2 to 2.7.0

DB function failed with error number 1064
You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'TYPE = MyISAM' at line 7 SQL=CREATE TABLE IF NOT EXISTS `jos_jshopping_products_extra_fields` ( `id` int(11) NOT NULL auto_increment, `allcats` tinyint(1) NOT NULL, `cats` text NOT NULL, `ordering` int(6) NOT NULL, PRIMARY KEY (`id`) ) TYPE = MyISAM;
DB function failed with error number 1064
You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'TYPE = MyISAM' at line 6 SQL=CREATE TABLE IF NOT EXISTS `jos_jshopping_products_extra_field_values` ( `id` int(11) NOT NULL auto_increment, `field_id` int(11) NOT NULL, `ordering` int(6) NOT NULL, PRIMARY KEY (`id`) ) TYPE = MyISAM;
Error install new language:
Table 'asbroad3_joomla_as.jos_jshopping_products_extra_fields' doesn't exist SQL=ALTER TABLE `jos_jshopping_products_extra_fields` ADD `name_en-GB` varchar(255) NOT NULL
Error install new language:
Table 'asbroad3_joomla_as.jos_jshopping_products_extra_field_values' doesn't exist SQL=ALTER TABLE `jos_jshopping_products_extra_field_values` ADD `name_en-GB` varchar(255) NOT NULL


and

Warning: Invalid argument supplied for foreach() in /home/asbroad3/public_html/components/com_jshopping/lib/multilangfield.php on line 63

Warning: Invalid argument supplied for foreach() in /home/asbroad3/public_html/components/com_jshopping/lib/multilangfield.php on line 63


How can I solve it, please? Thank you very much.


Joomla: 1.5.22
JoomShopping: 2.7.0
PHP: 5.2.17
MySQL: 4.1.22
Website Url: www.asbroadcast.com
 
12.11.2012 08:01
#2
admin
(Support Team)
User admin
Name: Admin
05.08.2010
Posts: 19416
Quote
Aw: Error while upgrade from 2.6.2 to 2.7.0

Execute query

CREATE TABLE IF NOT EXISTS `jos_jshopping_products_extra_fields` (
`id` int(11) NOT NULL auto_increment,
`allcats` tinyint(1) NOT NULL,
`cats` text NOT NULL,
`ordering` int(6) NOT NULL,
PRIMARY KEY (`id`)
);

CREATE TABLE IF NOT EXISTS `jos_jshopping_products_extra_field_values` (
`id` int(11) NOT NULL auto_increment,
`field_id` int(11) NOT NULL,
`ordering` int(6) NOT NULL,
PRIMARY KEY (`id`)
)

 
12.11.2012 09:21
#3
Scale
Joomshopping forum user no avatar
Name: Scale
11.01.2012
Posts: 2
Quote
Aw: Error while upgrade from 2.6.2 to 2.7.0

It works!
Thank you very much!


Last change: 12.11.2012 09:21
 


Copyrights MAXXmarketing GmbH. Alle Rechte vorbehalten
Durch die Nutzung dieser Website stimme ich zu, dass Cookies zur optimalen Gestaltung der Website sowie zur Analyse der Nutzung der Website verwendet werden. Weiterführende Informationen finden Sie hier. OK, einverstanden.